StreetFerret

You are not logged in. Would you like to login or register?



2/11/2021 5:45 am  #1


Unable to Subscribe

I've enjoyed using StreetFerret for free but felt it's time to subscribe.

Unfortunately, when I hit the Subscribe button on the Home page, nothing happens. I've been trying for a few days now with no success.

 

2/13/2021 6:58 pm  #2


Re: Unable to Subscribe

Glad to hear you're enjoying it, and sorry you're having trouble.  I've had some folks subscribe in the last few days so it does seem to be generally working.  Is it possible you have an ad blocker that might be interfering?  Did you notice your web browser reporting any Javascript errors? 

 

2/14/2021 7:09 pm  #3


Re: Unable to Subscribe

I've tried on a couple of devices and have had the same non-response on each where the button highlights but I'm not taken to a subscribe form. I don't have ad blockers on either device. I also haven't seen any Javascript errors when I hit the button.

I wonder if it could be geo-location related somehow. I'm in Australia - have people from Australia subscribed successfully?

     Thread Starter
 

2/22/2021 7:11 pm  #4


Re: Unable to Subscribe

I’m having the same issue not being able to subscribe.   I tried on laptop, IPhone and IPad.    Not able to subscribe on any device.

 

4/08/2021 4:43 am  #5


Re: Unable to Subscribe

Same here

 

4/13/2021 2:51 pm  #6


Re: Unable to Subscribe

I'm also hoping to subscribe and have not been able to. 

 

4/17/2021 8:50 am  #7


Re: Unable to Subscribe

For those having trouble subscribing -- it will not work if you're accessing StreetFerret on HTTP.

I've since updated the server settings, so it should always redirect you to the secure HTTPS side of the site!

https://streetferret.com

 

Board footera

 

Powered by Boardhost. Create a Free Forum